Lume Quality Issue

Discuss Christopher Ward watches
yorker
Posts: 2
Joined: Wed Jan 16, 2019 11:45 am

Lume Quality Issue

Post by yorker » Wed Jan 16, 2019 11:53 am

Initial post will be updated / rewritten by @yorker, having been deleted in error.

Guy (Admin Team).
Attachments
c601_re.jpg
c601_re2.jpg

User avatar
downer
Moderator
Moderator
Posts: 22922
Joined: Thu Dec 11, 2008 11:02 pm
CW-watches: 1
LE-foura: Yes
Location: UK

Re: Lume Quality Issue

Post by downer » Wed Jan 16, 2019 12:07 pm

Welcome to the forum. It's quite difficult to tell much from the attached pictures.

Are we looking at a shadow of the seconds hand on the minute hand, or is that area of darker lume the problem?

Any chance of some more conclusive pictures?
Richard

what-time-is-it
Senior Forumgod
Senior Forumgod
Posts: 3022
Joined: Thu Nov 24, 2016 11:53 am
CW-watches: 1

Re: Lume Quality Issue

Post by what-time-is-it » Wed Jan 16, 2019 12:19 pm

I think your pictures need to be far sharper, which will make it easier for others to see the problem including CW.

I've received Trident hands with inconsistent application of lume and I've sent them back - both were on similar black bezel/dial with white batons and hands. The poor application was more obvious to me in daylight as I don't think the lume is up to much anyway in it's present form.

If it's not right send it back and if they don't want to fix, ask for a refund.
Current collection incl Alpina, Breitling, Bulova, Casio, Citizen, Eterna, Oris, Rado, Raymond Weil, Rolex, Seiko, Tag, Timex, Tudor & Victorinox.

Chris

User avatar
Paul Drawmer
Senior Forumgod
Senior Forumgod
Posts: 2107
Joined: Fri Jan 04, 2013 9:42 am
CW-watches: 10
Location: Deddington, Oxfordshire
Contact:

Re: Lume Quality Issue

Post by Paul Drawmer » Wed Jan 16, 2019 1:51 pm

What a useless picture. We'll have to take your word for it!
Did you buy it new from CW and how long have you had it? Can you send it back under 60/60 (needs to be in unworn condition)
There's always time for one more.

TigerChris
Senior Forumgod
Senior Forumgod
Posts: 2553
Joined: Tue Mar 21, 2017 2:51 pm
CW-watches: 3

Re: Lume Quality Issue

Post by TigerChris » Wed Jan 16, 2019 1:53 pm

I’m struggling to see what the issue is here, or are we just going through ‘silly season’ again with people joining the forum just to have a moan and then disappearing? Seems to always happen at sale time!

User avatar
H0rati0
Senior Forumgod
Senior Forumgod
Posts: 1156
Joined: Wed Jun 27, 2018 7:49 am
CW-watches: 3
Location: Bayern

Re: Lume Quality Issue

Post by H0rati0 » Wed Jan 16, 2019 2:40 pm

I too cannot see what the issue is. The photo is not very revealing with the second hand obscuring the "problem area"?
"There is no beginning to enlightenment and no end to training" - Dogen Zenji (1200-1253)

TigerChris
Senior Forumgod
Senior Forumgod
Posts: 2553
Joined: Tue Mar 21, 2017 2:51 pm
CW-watches: 3

Re: Lume Quality Issue

Post by TigerChris » Wed Jan 16, 2019 2:51 pm

I’m confused (doesn’t take a lot I know! :D ) but where has the original post gone?

User avatar
downer
Moderator
Moderator
Posts: 22922
Joined: Thu Dec 11, 2008 11:02 pm
CW-watches: 1
LE-foura: Yes
Location: UK

Re: Lume Quality Issue

Post by downer » Wed Jan 16, 2019 2:54 pm

TigerChris wrote:I’m confused (doesn’t take a lot I know! :D ) but where has the original post gone?
The post must have been edited by the OP which then sends it through the approval loop again. Anyway, I just approved it again - although I’m on my phone and can’t easily see what has changed.
Richard

User avatar
downer
Moderator
Moderator
Posts: 22922
Joined: Thu Dec 11, 2008 11:02 pm
CW-watches: 1
LE-foura: Yes
Location: UK

Re: Lume Quality Issue

Post by downer » Wed Jan 16, 2019 2:56 pm

Edit. I can see now that the text has all gone but the pictures remain...
Richard

TigerChris
Senior Forumgod
Senior Forumgod
Posts: 2553
Joined: Tue Mar 21, 2017 2:51 pm
CW-watches: 3

Re: Lume Quality Issue

Post by TigerChris » Wed Jan 16, 2019 2:59 pm

downer wrote:
Wed Jan 16, 2019 2:56 pm
Edit. I can see now that the text has all gone but the pictures remain...
Weird hey :-k

Molan
Senior Expert
Senior Expert
Posts: 299
Joined: Sun Feb 28, 2016 12:52 pm
CW-watches: 25

Re: Lume Quality Issue

Post by Molan » Wed Jan 16, 2019 3:50 pm

Maybe he’s been bowled over by the responses?
C7 blue LE, red prototype, green panda & blue cosc auto, C60 pro vintage, Titanium v1, Black 40mm MKIII, C65 black, C65 GMT blue, C9 5 Day white & blue, C7 Bluebird, IRR, COSC, C1000 Cockpit, C70 BRG & VW4, C3 x3

yorker
Posts: 2
Joined: Wed Jan 16, 2019 11:45 am

Re: Lume Quality Issue

Post by yorker » Wed Jan 16, 2019 4:40 pm

I mistakenly removed the original content while I was trying to update on my phone. Although I have viewed this forum since 2016, but this is my first posting here (I even made my account today). I will take some more pictures after leaving my office.

User avatar
downer
Moderator
Moderator
Posts: 22922
Joined: Thu Dec 11, 2008 11:02 pm
CW-watches: 1
LE-foura: Yes
Location: UK

Re: Lume Quality Issue

Post by downer » Wed Jan 16, 2019 5:35 pm

yorker wrote:
Wed Jan 16, 2019 4:40 pm
I mistakenly removed the original content while I was trying to update on my phone. Although I have viewed this forum since 2016, but this is my first posting here (I even made my account today). I will take some more pictures after leaving my office.
Not to worry, it's easily done.
Richard

davroth
Posts: 4
Joined: Tue Jan 22, 2019 7:26 pm
CW-watches: 1

Re: Lume Quality Issue

Post by davroth » Tue Jan 22, 2019 7:30 pm

1st time poster. The lume on my 38mm burgundy bezel C60 is similar to the OP's. At first I thought it was my eyes playing tricks on me, but I've learned to live with it. I probably should have sent it back though.

Mine also happened to come on the wrong bracelet (all brushed vs polished center links) so it was a little frustrating compared to other purchases in the past from other companies.

TigerChris
Senior Forumgod
Senior Forumgod
Posts: 2553
Joined: Tue Mar 21, 2017 2:51 pm
CW-watches: 3

Re: Lume Quality Issue

Post by TigerChris » Wed Jan 23, 2019 3:28 am

davroth wrote:
Tue Jan 22, 2019 7:30 pm
1st time poster. The lume on my 38mm burgundy bezel C60 is similar to the OP's. At first I thought it was my eyes playing tricks on me, but I've learned to live with it. I probably should have sent it back though.

Mine also happened to come on the wrong bracelet (all brushed vs polished center links) so it was a little frustrating compared to other purchases in the past from other companies.
And what is the issue with the lume? The OP has never been here since and hasn’t posted any clearer pics, as promised. Those pics seem to show nothing wrong. So, if you can see an issue on those pics please enlighten me, or put up some clearer pics yourself if you can please so we can all see what the problem is.

Post Reply